Enterprise Phone Support Unavailable

Incident Report for DroneDeploy

Resolved

We have received word from our 3rd party provider that our Enterprise Support phone line is now working as expected.
Posted Sep 14, 2026 - 17:09 PDT

Investigating

Due to an outage with a 3rd party provider, the Enterprise Support phone line is currently unavailable. To contact Support, please email support@dronedeploy.com. We will provide updates as they arise and appreciate your patience.
Posted Sep 14, 2026 - 14:55 PDT
This incident affected: Support: Live Chat/Phone/Tickets.