Between 9:00AM PDT to 10:35 PDT (16:00 - 17:35 UTC) some users may have experienced difficulties loading the DroneDeploy web and mobile apps. Uploads, exports, and map processing may also have been affected. If you are expecting a map delivery, please allow some time and then attempt your upload again. The underlying cause has been corrected and no further impact is expected. We appreciate your patience.
Posted Aug 01, 2025 - 10:55 PDT
Monitoring
The DroneDeploy web and mobile apps are stabilizing and uploads are also working again. Engineering is continuing to monitor.
Posted Aug 01, 2025 - 10:11 PDT
Identified
Engineering has identified the cause of the issue and is implementing a fix. Users may start to see functionality come back online. We will continue to monitor to ensure stability moving forward.
Posted Aug 01, 2025 - 09:57 PDT
Investigating
Some users may be experiencing an issue where the DroneDeploy app is not loading on web or mobile. Engineering is aware an actively investigating.
Posted Aug 01, 2025 - 09:33 PDT
This incident affected: Web Server, Uploads, Robotics Portal, Web Application, Flight App, and Ground App.