Organization Administration Options Missing

Incident Report for DroneDeploy

Resolved

Between 11:21am and 12:37pm Pacific Time (19:21 and 20:37 UTC), some users experienced loss of access to Enterprise Organization Administration options.Engineering has reverted the change that caused the issue and no further impact is expected.
Posted Jan 24, 2025 - 12:48 PST

Investigating

Some enterprise users may be experiencing an issue where options to administer their DroneDeploy organization are missing from the left side panel. Engineering is actively investigating.
Posted Jan 24, 2025 - 12:35 PST
This incident affected: Web Application.