Projects not loading

Incident Report for DroneDeploy

Resolved

Between 1:00PM and 1:40PM Pacific time (20:00 and 20:40 UTC) some users may have experienced issues loading projects in DroneDeploy, as well as latency or errors when attempting to use DroneDeploy on web or mobile. If you attempted to upload or export during this window, please try your action again.
Posted Jul 14, 2026 - 14:04 PDT

Investigating

Some users may be experiencing an issue where projects are not loading on the dashboard.
Posted Jul 14, 2026 - 13:32 PDT
This incident affected: Map Processing, Web Server, APIs, Exports, Reports, Uploads, Automate, Web Application, Flight App, Ground App, Walks, Measurements, High Accuracy, App Market & Integrations, Annotations, Authentication, 3D, Dock Automation, Aerial Pro, Safety AI, and Enterprise Analytics Dashboard.