Outdated Enterprise Analytics Data

Incident Report for DroneDeploy

Resolved

A fix has been implemented to ensure a complete refresh of all Enterprise Analytics dashboard data. Please allow several hours for the dashboard to fully refresh.
Posted Feb 05, 2026 - 18:12 PST

Investigating

Some users of the Enterprise Analytics dashboard may see data that is up to 2.5 days old due to an infrastructure update. A fix is being deployed to quickly refresh the data and ensure it remains up to date.
Posted Feb 05, 2026 - 11:41 PST
This incident affected: Enterprise Analytics Dashboard.