Live Maps not processing

Incident Report for DroneDeploy

Resolved

Between 2:30 PM Pacific Time on 05/21 and 6:30 PM on 05/30 (21:30 on 05/21 and 01:50 UTC on 05/30) some users may have experienced an issue with processing Live Map results. Engineering has corrected the issue and no further impact is expected.
Posted May 30, 2025 - 18:42 PDT

Investigating

Some users may be experiencing an issue when using Live Map, where the map is viewable during flight but does not sync for later viewing. Engineering is actively investigating.
Posted May 30, 2025 - 17:03 PDT
This incident affected: Map Processing.