Slow performance

Incident Report for DroneDeploy

Resolved

Performance should be back to normal.
Posted Jan 18, 2017 - 21:08 PST

Investigating

htttps://www.dronedeploy.com is experiencing very slow load times. Pages do eventually load, but the performance is clearly unacceptable.
Posted Jan 18, 2017 - 20:31 PST