Map Processing Delays

Incident Report for DroneDeploy

Resolved

Our Engineering team has confirmed there is no customer-facing impact for the reported issue. We apologize for the incorrect incident notification.
Posted Jun 02, 2025 - 15:21 PDT

Investigating

Some users may be seeing delays in map or walk processing, beginning at approximately 1:00 PM Pacific Time (20:00 UTC). Engineering is actively investigating.
Posted Jun 02, 2025 - 14:41 PDT
This incident affected: Map Processing and Walks.