DroneDeploy Academy degraded availability
Incident Report for DroneDeploy
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 18:36 PST
Investigating
We are currently investigating intermittent reports of users being unable to log into DroneDeploy Academy.
Posted Mar 05, 2021 - 16:44 PST
This incident affected: Help Center.