Cannot create new user accounts

Incident Report for DroneDeploy

Resolved

This incident has been resolved.
Posted Oct 27, 2021 - 12:02 PDT

Update

We are continuing to investigate this issue.
Posted Oct 27, 2021 - 12:02 PDT

Investigating

We have identified an issue with new user sign up. We are working to correct the problem. Please check back for more information.
Posted Oct 27, 2021 - 10:31 PDT
This incident affected: APIs.