Intermittent issues loading elevation layer

Incident Report for DroneDeploy

Resolved

Between 7:45AM and 1:20PM Pacific Time (14:45 and 20:20 UTC), some users may have experienced issues with rendering the elevation layer. Engineering has made changes to prevent further impact.
Posted Jul 30, 2026 - 15:18 PDT

Monitoring

Our Engineering team has implemented a fix for the issue of intermittent failures rendering the elevation layer. Service has returned to normal, but we are continuing to monitor to ensure ongoing stability.
Posted Jul 30, 2026 - 13:37 PDT

Identified

Some users may be experiencing intermittent failures rendering the elevation layer in DroneDeploy. Engineering is working on a fix.
Posted Jul 30, 2026 - 12:55 PDT
This incident affected: Measurements.